summaryrefslogtreecommitdiffstats
path: root/tests/run-make/test-harness/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/test-harness/Makefile')
-rw-r--r--tests/run-make/test-harness/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/test-harness/Makefile b/tests/run-make/test-harness/Makefile
new file mode 100644
index 000000000..ee8c9294f
--- /dev/null
+++ b/tests/run-make/test-harness/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ # check that #[cfg_attr(..., ignore)] does the right thing.
+ $(RUSTC) --test test-ignore-cfg.rs --cfg ignorecfg
+ $(call RUN,test-ignore-cfg) | $(CGREP) 'shouldnotignore ... ok' 'shouldignore ... ignored'
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -e "^i\.$$"
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -v 'should'