summaryrefslogtreecommitdiffstats
path: root/tests/run-make/use-suggestions-rust-2018/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/use-suggestions-rust-2018/Makefile')
-rw-r--r--tests/run-make/use-suggestions-rust-2018/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/run-make/use-suggestions-rust-2018/Makefile b/tests/run-make/use-suggestions-rust-2018/Makefile
new file mode 100644
index 000000000..37cd6283c
--- /dev/null
+++ b/tests/run-make/use-suggestions-rust-2018/Makefile
@@ -0,0 +1,7 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) ep-nested-lib.rs
+
+ $(RUSTC) use-suggestions.rs --edition=2018 --extern ep_nested_lib=$(TMPDIR)/libep_nested_lib.rlib 2>&1 | $(CGREP) "use ep_nested_lib::foo::bar::Baz"
+