summaryrefslogtreecommitdiffstats
path: root/tests/run-make/wasm-custom-section/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/wasm-custom-section/Makefile')
-rw-r--r--tests/run-make/wasm-custom-section/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/wasm-custom-section/Makefile b/tests/run-make/wasm-custom-section/Makefile
new file mode 100644
index 000000000..92b0802e3
--- /dev/null
+++ b/tests/run-make/wasm-custom-section/Makefile
@@ -0,0 +1,8 @@
+include ../../run-make-fulldeps/tools.mk
+
+# only-wasm32-bare
+
+all:
+ $(RUSTC) foo.rs --target wasm32-unknown-unknown
+ $(RUSTC) bar.rs -C lto -O --target wasm32-unknown-unknown
+ $(NODE) foo.js $(TMPDIR)/bar.wasm