summaryrefslogtreecommitdiffstats
path: root/tests/run-make/windows-binary-no-external-deps
diff options
context:
space:
mode:
Diffstat (limited to 'tests/run-make/windows-binary-no-external-deps')
-rw-r--r--tests/run-make/windows-binary-no-external-deps/Makefile9
-rw-r--r--tests/run-make/windows-binary-no-external-deps/hello.rs3
2 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/windows-binary-no-external-deps/Makefile b/tests/run-make/windows-binary-no-external-deps/Makefile
new file mode 100644
index 000000000..8960020fe
--- /dev/null
+++ b/tests/run-make/windows-binary-no-external-deps/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# only-windows
+
+PATH=$(SYSTEMROOT)/system32
+
+all:
+ $(RUSTC) hello.rs
+ $(TMPDIR)/hello.exe
diff --git a/tests/run-make/windows-binary-no-external-deps/hello.rs b/tests/run-make/windows-binary-no-external-deps/hello.rs
new file mode 100644
index 000000000..47ad8c634
--- /dev/null
+++ b/tests/run-make/windows-binary-no-external-deps/hello.rs
@@ -0,0 +1,3 @@
+fn main() {
+ println!("Hello World!");
+}