summaryrefslogtreecommitdiffstats
path: root/tests/ui/check-cfg/cargo-feature.none.stderr
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ui/check-cfg/cargo-feature.none.stderr')
-rw-r--r--tests/ui/check-cfg/cargo-feature.none.stderr31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/ui/check-cfg/cargo-feature.none.stderr b/tests/ui/check-cfg/cargo-feature.none.stderr
new file mode 100644
index 000000000..44c8f7e30
--- /dev/null
+++ b/tests/ui/check-cfg/cargo-feature.none.stderr
@@ -0,0 +1,31 @@
+warning: unexpected `cfg` condition name: `feature`
+ --> $DIR/cargo-feature.rs:13:7
+ |
+LL | #[cfg(feature = "serde")]
+ | ^^^^^^^^^^^^^^^^^
+ |
+ = help: consider defining some features in `Cargo.toml`
+ = note: see <https://doc.rust-lang.org/nightly/cargo/reference/unstable.html#check-cfg> for more information about checking conditional configuration
+ = note: `#[warn(unexpected_cfgs)]` on by default
+
+warning: unexpected `cfg` condition name: `tokio_unstable`
+ --> $DIR/cargo-feature.rs:18:7
+ |
+LL | #[cfg(tokio_unstable)]
+ | ^^^^^^^^^^^^^^
+ |
+ = help: expected names are: `debug_assertions`, `doc`, `doctest`, `miri`, `overflow_checks`, `panic`, `proc_macro`, `relocation_model`, `sanitize`, `sanitizer_cfi_generalize_pointers`, `sanitizer_cfi_normalize_integers`, `target_abi`, `target_arch`, `target_endian`, `target_env`, `target_family`, `target_feature`, `target_has_atomic`, `target_has_atomic_equal_alignment`, `target_has_atomic_load_store`, `target_os`, `target_pointer_width`, `target_thread_local`, `target_vendor`, `test`, `unix`, `windows`
+ = help: consider using a Cargo feature instead or adding `println!("cargo:rustc-check-cfg=cfg(tokio_unstable)");` to the top of a `build.rs`
+ = note: see <https://doc.rust-lang.org/nightly/cargo/reference/unstable.html#check-cfg> for more information about checking conditional configuration
+
+warning: unexpected `cfg` condition name: `CONFIG_NVME`
+ --> $DIR/cargo-feature.rs:22:7
+ |
+LL | #[cfg(CONFIG_NVME = "m")]
+ | ^^^^^^^^^^^^^^^^^
+ |
+ = help: consider using a Cargo feature instead or adding `println!("cargo:rustc-check-cfg=cfg(CONFIG_NVME, values(\"m\"))");` to the top of a `build.rs`
+ = note: see <https://doc.rust-lang.org/nightly/cargo/reference/unstable.html#check-cfg> for more information about checking conditional configuration
+
+warning: 3 warnings emitted
+