summaryrefslogtreecommitdiffstats
path: root/vendor/addr2line/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/addr2line/Cargo.toml')
-rw-r--r--vendor/addr2line/Cargo.toml72
1 files changed, 47 insertions, 25 deletions
diff --git a/vendor/addr2line/Cargo.toml b/vendor/addr2line/Cargo.toml
index 358995e53..2b51239b8 100644
--- a/vendor/addr2line/Cargo.toml
+++ b/vendor/addr2line/Cargo.toml
@@ -3,38 +3,40 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
name = "addr2line"
-version = "0.17.0"
-exclude = ["/benches/*", "/fixtures/*", ".github"]
+version = "0.19.0"
+exclude = [
+ "/benches/*",
+ "/fixtures/*",
+ ".github",
+]
description = "A cross-platform symbolication library written in Rust, using `gimli`"
documentation = "https://docs.rs/addr2line"
readme = "./README.md"
-keywords = ["DWARF", "debug", "elf", "symbolicate", "atos"]
+keywords = [
+ "DWARF",
+ "debug",
+ "elf",
+ "symbolicate",
+ "atos",
+]
categories = ["development-tools::debugging"]
license = "Apache-2.0 OR MIT"
repository = "https://github.com/gimli-rs/addr2line"
+
[profile.bench]
codegen-units = 1
debug = true
-split-debuginfo = "packed"
-
-[profile.dev]
-split-debuginfo = "packed"
[profile.release]
debug = true
-split-debuginfo = "packed"
-
-[profile.test]
-split-debuginfo = "packed"
[[example]]
name = "addr2line"
@@ -52,6 +54,7 @@ required-features = ["default"]
[[test]]
name = "parse"
required-features = ["std-object"]
+
[dependencies.alloc]
version = "1.0.0"
optional = true
@@ -67,7 +70,8 @@ optional = true
package = "rustc-std-workspace-core"
[dependencies.cpp_demangle]
-version = "0.3"
+version = "0.4"
+features = ["alloc"]
optional = true
default-features = false
@@ -77,12 +81,12 @@ optional = true
default-features = false
[dependencies.gimli]
-version = "0.26"
+version = "0.27.0"
features = ["read"]
default-features = false
[dependencies.object]
-version = "0.27.1"
+version = "0.30.0"
features = ["read"]
optional = true
default-features = false
@@ -95,17 +99,18 @@ optional = true
version = "1"
optional = true
default-features = false
+
[dev-dependencies.backtrace]
version = "0.3.13"
[dev-dependencies.clap]
-version = "2"
+version = "3.1.6"
[dev-dependencies.findshlibs]
version = "0.10"
-[dev-dependencies.memmap]
-version = "0.7"
+[dev-dependencies.memmap2]
+version = "0.5.5"
[dev-dependencies.rustc-test]
version = "0.3"
@@ -114,7 +119,24 @@ version = "0.3"
version = "2"
[features]
-default = ["rustc-demangle", "cpp_demangle", "std-object", "fallible-iterator", "smallvec"]
-rustc-dep-of-std = ["core", "alloc", "compiler_builtins", "gimli/rustc-dep-of-std"]
+default = [
+ "rustc-demangle",
+ "cpp_demangle",
+ "std-object",
+ "fallible-iterator",
+ "smallvec",
+]
+rustc-dep-of-std = [
+ "core",
+ "alloc",
+ "compiler_builtins",
+ "gimli/rustc-dep-of-std",
+]
std = ["gimli/std"]
-std-object = ["std", "object", "object/std", "object/compression", "gimli/endian-reader"]
+std-object = [
+ "std",
+ "object",
+ "object/std",
+ "object/compression",
+ "gimli/endian-reader",
+]