summaryrefslogtreecommitdiffstats
path: root/vendor/askama/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/askama/Cargo.toml')
-rw-r--r--vendor/askama/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/vendor/askama/Cargo.toml b/vendor/askama/Cargo.toml
new file mode 100644
index 000000000..bb6ad7aed
--- /dev/null
+++ b/vendor/askama/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "askama"
+version = "0.11.0"
+description = "Type-safe, compiled Jinja-like templates for Rust"
+homepage = "https://github.com/djc/askama"
+documentation = "https://docs.rs/askama"
+readme = "../README.md"
+keywords = ["markup", "template", "jinja2", "html"]
+categories = ["template-engine"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/djc/askama"
+[package.metadata.docs.rs]
+features = ["config", "humansize", "num-traits", "serde-json", "serde-yaml"]
+[dependencies.askama_derive]
+version = "0.11.0"
+
+[dependencies.askama_escape]
+version = "0.10"
+
+[dependencies.askama_shared]
+version = "0.12.0"
+default-features = false
+
+[dependencies.mime]
+version = "0.3"
+optional = true
+
+[dependencies.mime_guess]
+version = "2"
+optional = true
+
+[features]
+config = ["askama_derive/config", "askama_shared/config"]
+default = ["config", "humansize", "num-traits", "urlencode"]
+humansize = ["askama_shared/humansize"]
+num-traits = ["askama_shared/num-traits"]
+serde-json = ["askama_shared/json"]
+serde-yaml = ["askama_shared/yaml"]
+urlencode = ["askama_shared/percent-encoding"]
+with-actix-web = ["askama_derive/actix-web"]
+with-axum = ["askama_derive/axum"]
+with-gotham = ["askama_derive/gotham"]
+with-iron = ["askama_derive/iron"]
+with-mendes = ["askama_derive/mendes"]
+with-rocket = ["askama_derive/rocket"]
+with-tide = ["askama_derive/tide"]
+with-warp = ["askama_derive/warp"]
+[badges.maintenance]
+status = "actively-developed"