summaryrefslogtreecommitdiffstats
path: root/vendor/bstr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/bstr/Cargo.toml')
-rw-r--r--vendor/bstr/Cargo.toml63
1 files changed, 0 insertions, 63 deletions
diff --git a/vendor/bstr/Cargo.toml b/vendor/bstr/Cargo.toml
deleted file mode 100644
index 0f206ba5a..000000000
--- a/vendor/bstr/Cargo.toml
+++ /dev/null
@@ -1,63 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "bstr"
-version = "0.2.17"
-authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/.github"]
-description = "A string type that is not required to be valid UTF-8."
-homepage = "https://github.com/BurntSushi/bstr"
-documentation = "https://docs.rs/bstr"
-readme = "README.md"
-keywords = ["string", "str", "byte", "bytes", "text"]
-categories = ["text-processing", "encoding"]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/BurntSushi/bstr"
-[profile.release]
-debug = true
-
-[lib]
-bench = false
-[dependencies.lazy_static]
-version = "1.2.0"
-optional = true
-
-[dependencies.memchr]
-version = "2.4.0"
-default-features = false
-
-[dependencies.regex-automata]
-version = "0.1.5"
-optional = true
-default-features = false
-
-[dependencies.serde]
-version = "1.0.85"
-optional = true
-default-features = false
-[dev-dependencies.quickcheck]
-version = "1"
-default-features = false
-
-[dev-dependencies.ucd-parse]
-version = "0.1.3"
-
-[dev-dependencies.unicode-segmentation]
-version = "1.2.1"
-
-[features]
-default = ["std", "unicode"]
-serde1 = ["std", "serde1-nostd", "serde/std"]
-serde1-nostd = ["serde"]
-std = ["memchr/std"]
-unicode = ["lazy_static", "regex-automata"]