summaryrefslogtreecommitdiffstats
path: root/vendor/bstr/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/bstr/Cargo.toml')
-rw-r--r--vendor/bstr/Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/vendor/bstr/Cargo.toml b/vendor/bstr/Cargo.toml
index f644ee2a8..2db4367c1 100644
--- a/vendor/bstr/Cargo.toml
+++ b/vendor/bstr/Cargo.toml
@@ -13,9 +13,12 @@
edition = "2021"
rust-version = "1.60"
name = "bstr"
-version = "1.5.0"
+version = "1.6.2"
authors = ["Andrew Gallant <jamslam@gmail.com>"]
-exclude = ["/.github"]
+exclude = [
+ "/.github",
+ "/scripts",
+]
description = "A string type that is not required to be valid UTF-8."
homepage = "https://github.com/BurntSushi/bstr"
documentation = "https://docs.rs/bstr"
@@ -74,15 +77,12 @@ required-features = [
]
[dependencies.memchr]
-version = "2.4.0"
+version = "2.6.1"
default-features = false
-[dependencies.once_cell]
-version = "1.14.0"
-optional = true
-
[dependencies.regex-automata]
-version = "0.1.5"
+version = "0.3.0"
+features = ["dfa-search"]
optional = true
default-features = false
@@ -102,7 +102,10 @@ version = "0.1.3"
version = "1.2.1"
[features]
-alloc = ["serde?/alloc"]
+alloc = [
+ "memchr/alloc",
+ "serde?/alloc",
+]
default = [
"std",
"unicode",
@@ -113,7 +116,4 @@ std = [
"memchr/std",
"serde?/std",
]
-unicode = [
- "dep:once_cell",
- "dep:regex-automata",
-]
+unicode = ["dep:regex-automata"]