summaryrefslogtreecommitdiffstats
path: root/vendor/bytesize/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/bytesize/Cargo.toml')
-rw-r--r--vendor/bytesize/Cargo.toml35
1 files changed, 27 insertions, 8 deletions
diff --git a/vendor/bytesize/Cargo.toml b/vendor/bytesize/Cargo.toml
index 5265e11b9..475fef195 100644
--- a/vendor/bytesize/Cargo.toml
+++ b/vendor/bytesize/Cargo.toml
@@ -3,25 +3,44 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
name = "bytesize"
-version = "1.0.1"
+version = "1.2.0"
authors = ["Hyunsik Choi <hyunsik.choi@gmail.com>"]
description = "an utility for human-readable bytes representations"
homepage = "https://github.com/hyunsik/bytesize/"
documentation = "https://docs.rs/bytesize/"
readme = "README.md"
-keywords = ["byte", "byte-size", "utility", "human-readable", "format"]
+keywords = [
+ "byte",
+ "byte-size",
+ "utility",
+ "human-readable",
+ "format",
+]
license = "Apache-2.0"
repository = "https://github.com/hyunsik/bytesize/"
+
[dependencies.serde]
version = "1.0"
-features = ["derive"]
optional = true
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.toml]
+version = "0.5"
+
+[features]
+default = []
+serde = ["dep:serde"]