summaryrefslogtreecommitdiffstats
path: root/vendor/chrono/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/chrono/Cargo.toml')
-rw-r--r--vendor/chrono/Cargo.toml17
1 files changed, 7 insertions, 10 deletions
diff --git a/vendor/chrono/Cargo.toml b/vendor/chrono/Cargo.toml
index eaf0e6945..7f49bad0b 100644
--- a/vendor/chrono/Cargo.toml
+++ b/vendor/chrono/Cargo.toml
@@ -10,9 +10,10 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.56.0"
name = "chrono"
-version = "0.4.24"
+version = "0.4.26"
exclude = ["/ci/*"]
description = "Date and time library for Rust"
homepage = "https://github.com/chronotope/chrono"
@@ -62,10 +63,6 @@ optional = true
version = "0.4.0"
optional = true
-[dependencies.num-integer]
-version = "0.1.36"
-default-features = false
-
[dependencies.num-traits]
version = "0.2"
default-features = false
@@ -97,10 +94,6 @@ version = "1.3.0"
[dev-dependencies.doc-comment]
version = "0.3"
-[dev-dependencies.num-iter]
-version = "0.1.35"
-default-features = false
-
[dev-dependencies.serde_derive]
version = "1"
default-features = false
@@ -146,6 +139,9 @@ optional = true
[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dev-dependencies.wasm-bindgen-test]
version = "0.3"
+[target."cfg(target_os = \"android\")".dependencies.android-tzdata]
+version = "0.1.1"
+
[target."cfg(unix)".dependencies.iana-time-zone]
version = "0.1.45"
features = ["fallback"]
@@ -158,5 +154,6 @@ features = [
"minwinbase",
"minwindef",
"timezoneapi",
+ "sysinfoapi",
]
optional = true