summaryrefslogtreecommitdiffstats
path: root/vendor/ciborium/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ciborium/Cargo.toml')
-rw-r--r--vendor/ciborium/Cargo.toml64
1 files changed, 64 insertions, 0 deletions
diff --git a/vendor/ciborium/Cargo.toml b/vendor/ciborium/Cargo.toml
new file mode 100644
index 000000000..f82b8b903
--- /dev/null
+++ b/vendor/ciborium/Cargo.toml
@@ -0,0 +1,64 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56"
+name = "ciborium"
+version = "0.2.1"
+authors = ["Nathaniel McCallum <npmccallum@profian.com>"]
+description = "serde implementation of CBOR using ciborium-basic"
+homepage = "https://github.com/enarx/ciborium"
+readme = "README.md"
+keywords = ["cbor", "serde"]
+categories = ["data-structures", "embedded", "encoding", "no-std", "parsing"]
+license = "Apache-2.0"
+repository = "https://github.com/enarx/ciborium"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.ciborium-io]
+version = "0.2.1"
+features = ["alloc"]
+
+[dependencies.ciborium-ll]
+version = "0.2.1"
+
+[dependencies.serde]
+version = "1.0"
+features = ["alloc", "derive"]
+default-features = false
+[dev-dependencies.hex]
+version = "0.4"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.rstest]
+version = "0.11"
+
+[dev-dependencies.serde_bytes]
+version = "0.11"
+
+[features]
+default = ["std"]
+std = ["ciborium-io/std", "serde/std"]
+[badges.github]
+repository = "enarx/ciborium"
+workflow = "test"
+
+[badges.is-it-maintained-issue-resolution]
+repository = "enarx/ciborium"
+
+[badges.is-it-maintained-open-issues]
+repository = "enarx/ciborium"
+
+[badges.maintenance]
+status = "actively-developed"