summaryrefslogtreecommitdiffstats
path: root/vendor/crypto-bigint/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/crypto-bigint/Cargo.toml')
-rw-r--r--vendor/crypto-bigint/Cargo.toml107
1 files changed, 107 insertions, 0 deletions
diff --git a/vendor/crypto-bigint/Cargo.toml b/vendor/crypto-bigint/Cargo.toml
new file mode 100644
index 000000000..20d8afd9f
--- /dev/null
+++ b/vendor/crypto-bigint/Cargo.toml
@@ -0,0 +1,107 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.57"
+name = "crypto-bigint"
+version = "0.4.9"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of a big integer library which has been designed from
+the ground-up for use in cryptographic applications. Provides constant-time,
+no_std-friendly implementations of modern formulas using const generics.
+"""
+readme = "README.md"
+keywords = [
+ "arbitrary",
+ "crypto",
+ "bignum",
+ "integer",
+ "precision",
+]
+categories = [
+ "algorithms",
+ "cryptography",
+ "data-structures",
+ "mathematics",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/crypto-bigint"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.der]
+version = "0.6"
+optional = true
+default-features = false
+
+[dependencies.generic-array]
+version = "0.14"
+optional = true
+
+[dependencies.rand_core]
+version = "0.6"
+optional = true
+
+[dependencies.rlp]
+version = "0.5"
+optional = true
+default-features = false
+
+[dependencies.serdect]
+version = "0.1"
+optional = true
+default-features = false
+
+[dependencies.subtle]
+version = "2.4"
+default-features = false
+
+[dependencies.zeroize]
+version = "1"
+optional = true
+default-features = false
+
+[dev-dependencies.bincode]
+version = "1"
+
+[dev-dependencies.hex-literal]
+version = "0.3"
+
+[dev-dependencies.num-bigint]
+version = "0.4"
+
+[dev-dependencies.num-traits]
+version = "0.2"
+
+[dev-dependencies.proptest]
+version = "1"
+
+[dev-dependencies.rand_chacha]
+version = "0.3"
+
+[dev-dependencies.rand_core]
+version = "0.6"
+features = ["std"]
+
+[features]
+alloc = []
+default = ["rand"]
+rand = ["rand_core/std"]
+serde = ["serdect"]