summaryrefslogtreecommitdiffstats
path: root/vendor/csv/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/csv/Cargo.toml')
-rw-r--r--vendor/csv/Cargo.toml73
1 files changed, 73 insertions, 0 deletions
diff --git a/vendor/csv/Cargo.toml b/vendor/csv/Cargo.toml
new file mode 100644
index 000000000..1c0b40c87
--- /dev/null
+++ b/vendor/csv/Cargo.toml
@@ -0,0 +1,73 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.60"
+name = "csv"
+version = "1.2.1"
+authors = ["Andrew Gallant <jamslam@gmail.com>"]
+exclude = [
+ "/.github",
+ "/ci/*",
+ "/scripts/*",
+]
+description = "Fast CSV parsing with support for serde."
+homepage = "https://github.com/BurntSushi/rust-csv"
+documentation = "https://docs.rs/csv"
+readme = "README.md"
+keywords = [
+ "csv",
+ "comma",
+ "parser",
+ "delimited",
+ "serde",
+]
+categories = [
+ "encoding",
+ "parser-implementations",
+]
+license = "Unlicense/MIT"
+repository = "https://github.com/BurntSushi/rust-csv"
+resolver = "2"
+
+[profile.bench]
+debug = true
+
+[profile.release]
+debug = true
+
+[lib]
+bench = false
+
+[dependencies.csv-core]
+version = "0.1.10"
+
+[dependencies.itoa]
+version = "1"
+
+[dependencies.ryu]
+version = "1"
+
+[dependencies.serde]
+version = "1.0.55"
+
+[dev-dependencies.bstr]
+version = "1.2.0"
+features = [
+ "alloc",
+ "serde",
+]
+default-features = false
+
+[dev-dependencies.serde]
+version = "1.0.55"
+features = ["derive"]