summaryrefslogtreecommitdiffstats
path: root/vendor/derive_builder/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/derive_builder/Cargo.toml')
-rw-r--r--vendor/derive_builder/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/vendor/derive_builder/Cargo.toml b/vendor/derive_builder/Cargo.toml
new file mode 100644
index 000000000..cf6a60291
--- /dev/null
+++ b/vendor/derive_builder/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "derive_builder"
+version = "0.12.0"
+authors = [
+ "Colin Kiegel <kiegel@gmx.de>",
+ "Pascal Hertleif <killercup@gmail.com>",
+ "Jan-Erik Rediger <janerik@fnordig.de>",
+ "Ted Driggs <ted.driggs@outlook.com>",
+]
+description = "Rust macro to automatically implement the builder pattern for arbitrary structs."
+documentation = "https://docs.rs/derive_builder/0.12.0"
+readme = "README.md"
+keywords = [
+ "derive",
+ "macro",
+ "builder",
+ "setter",
+ "struct",
+]
+categories = [
+ "development-tools",
+ "rust-patterns",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/colin-kiegel/rust-derive-builder"
+
+[dependencies.derive_builder_macro]
+version = "=0.12.0"
+
+[dev-dependencies.pretty_assertions]
+version = "0.6.1"
+
+[dev-dependencies.rustversion]
+version = "1.0.4"
+
+[dev-dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1"
+
+[features]
+clippy = ["derive_builder_macro/clippy"]
+default = ["std"]
+std = []
+
+[target."cfg(compiletests)".dev-dependencies.trybuild]
+version = "1.0.38"