summaryrefslogtreecommitdiffstats
path: root/vendor/derive_setters/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/derive_setters/Cargo.toml')
-rw-r--r--vendor/derive_setters/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/vendor/derive_setters/Cargo.toml b/vendor/derive_setters/Cargo.toml
new file mode 100644
index 000000000..a75179e10
--- /dev/null
+++ b/vendor/derive_setters/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "derive_setters"
+version = "0.1.6"
+authors = ["Lymia Aluysia <lymia@lymiahugs.com>"]
+description = "Rust macro to automatically generates setter methods for a struct's fields."
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Lymia/derive_setters"
+
+[lib]
+proc-macro = true
+
+[dependencies.darling]
+version = "0.20"
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "2"
+
+[features]
+nightly = ["proc-macro2/nightly"]