summaryrefslogtreecommitdiffstats
path: root/vendor/ed25519-compact/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/ed25519-compact/Cargo.toml')
-rw-r--r--vendor/ed25519-compact/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/vendor/ed25519-compact/Cargo.toml b/vendor/ed25519-compact/Cargo.toml
new file mode 100644
index 000000000..ef4bdc290
--- /dev/null
+++ b/vendor/ed25519-compact/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "ed25519-compact"
+version = "2.0.4"
+authors = ["Frank Denis <github@pureftpd.org>"]
+description = "A small, self-contained, wasm-friendly Ed25519 implementation"
+homepage = "https://github.com/jedisct1/rust-ed25519-compact"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "ed25519",
+ "x25519",
+ "eddsa",
+ "signature",
+]
+categories = [
+ "algorithms",
+ "cryptography",
+ "no-std",
+ "wasm",
+]
+license = "MIT"
+repository = "https://github.com/jedisct1/rust-ed25519-compact"
+
+[dependencies.ct-codecs]
+version = "1.1"
+optional = true
+
+[dependencies.ed25519]
+version = "1.5"
+optional = true
+
+[dependencies.getrandom]
+version = "0.2"
+optional = true
+
+[dev-dependencies.ct-codecs]
+version = "1.1"
+
+[dev-dependencies.getrandom]
+version = "0.2"
+
+[features]
+blind-keys = []
+default = [
+ "random",
+ "std",
+ "x25519",
+ "pem",
+]
+disable-signatures = []
+opt_size = []
+pem = ["ct-codecs"]
+random = ["getrandom"]
+self-verify = []
+std = []
+traits = ["ed25519"]
+x25519 = []