summaryrefslogtreecommitdiffstats
path: root/vendor/flate2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/flate2/Cargo.toml')
-rw-r--r--vendor/flate2/Cargo.toml17
1 files changed, 14 insertions, 3 deletions
diff --git a/vendor/flate2/Cargo.toml b/vendor/flate2/Cargo.toml
index 68516e5e7..1cc1577d3 100644
--- a/vendor/flate2/Cargo.toml
+++ b/vendor/flate2/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "flate2"
-version = "1.0.25"
+version = "1.0.26"
authors = [
"Alex Crichton <alex@alexcrichton.com>",
"Josh Triplett <josh@joshtriplett.org>",
@@ -39,6 +39,13 @@ categories = [
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/flate2-rs"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.cloudflare-zlib-sys]
version = "0.3.0"
optional = true
@@ -56,7 +63,7 @@ optional = true
default-features = false
[dependencies.miniz_oxide]
-version = "0.6.0"
+version = "0.7.1"
features = ["with-alloc"]
optional = true
default-features = false
@@ -81,6 +88,10 @@ zlib = [
"any_zlib",
"libz-sys",
]
+zlib-default = [
+ "any_zlib",
+ "libz-sys/default",
+]
zlib-ng = [
"any_zlib",
"libz-ng-sys",
@@ -91,6 +102,6 @@ zlib-ng-compat = [
]
[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.miniz_oxide]
-version = "0.6.0"
+version = "0.7.1"
features = ["with-alloc"]
default-features = false