summaryrefslogtreecommitdiffstats
path: root/vendor/fs-err/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/fs-err/Cargo.toml')
-rw-r--r--vendor/fs-err/Cargo.toml45
1 files changed, 35 insertions, 10 deletions
diff --git a/vendor/fs-err/Cargo.toml b/vendor/fs-err/Cargo.toml
index 62c4c651c..07bada50a 100644
--- a/vendor/fs-err/Cargo.toml
+++ b/vendor/fs-err/Cargo.toml
@@ -3,28 +3,53 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "fs-err"
-version = "2.5.0"
+version = "2.8.1"
authors = ["Andrew Hickman <andrew.hickman1@sky.com>"]
+exclude = [
+ ".github",
+ ".gitignore",
+ "README.tpl",
+]
description = "A drop-in replacement for std::fs with more helpful error messages."
documentation = "https://docs.rs/fs-err"
readme = "README.md"
-categories = ["command-line-interface", "filesystem"]
+categories = [
+ "command-line-interface",
+ "filesystem",
+]
license = "MIT/Apache-2.0"
repository = "https://github.com/andrewhickman/fs-err"
+[package.metadata.release]
+tag-name = "{{version}}"
+sign-tag = true
+
+[[package.metadata.release.pre-release-replacements]]
+file = "src/lib.rs"
+search = 'html_root_url = "https://docs\.rs/fs-err/.*?"'
+replace = "html_root_url = \"https://docs.rs/fs-err/{{version}}\""
+exactly = 1
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies]
+
[dev-dependencies.serde_json]
-version = "1.0.48"
+version = "1.0.64"
-[dev-dependencies.version-sync]
-version = "0.8.1"
+[features]
+io_safety = []