summaryrefslogtreecommitdiffstats
path: root/vendor/futures-util/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/futures-util/Cargo.toml')
-rw-r--r--vendor/futures-util/Cargo.toml82
1 files changed, 62 insertions, 20 deletions
diff --git a/vendor/futures-util/Cargo.toml b/vendor/futures-util/Cargo.toml
index f18cfbcf9..a3b9cadf2 100644
--- a/vendor/futures-util/Cargo.toml
+++ b/vendor/futures-util/Cargo.toml
@@ -11,44 +11,52 @@
[package]
edition = "2018"
-rust-version = "1.45"
+rust-version = "1.56"
name = "futures-util"
-version = "0.3.19"
-description = "Common utilities and extension traits for the futures-rs library.\n"
+version = "0.3.28"
+description = """
+Common utilities and extension traits for the futures-rs library.
+"""
homepage = "https://rust-lang.github.io/futures-rs"
+readme = "README.md"
license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/futures-rs"
+
[package.metadata.docs.rs]
all-features = true
-rustdoc-args = ["--cfg", "docsrs"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.futures-channel]
-version = "0.3.19"
+version = "0.3.28"
features = ["std"]
optional = true
default-features = false
[dependencies.futures-core]
-version = "0.3.19"
+version = "0.3.28"
default-features = false
[dependencies.futures-io]
-version = "0.3.19"
+version = "0.3.28"
features = ["std"]
optional = true
default-features = false
[dependencies.futures-macro]
-version = "=0.3.19"
+version = "=0.3.28"
optional = true
default-features = false
[dependencies.futures-sink]
-version = "0.3.19"
+version = "0.3.28"
optional = true
default-features = false
[dependencies.futures-task]
-version = "0.3.19"
+version = "0.3.28"
default-features = false
[dependencies.futures_01]
@@ -61,7 +69,7 @@ version = "2.2"
optional = true
[dependencies.pin-project-lite]
-version = "0.2.4"
+version = "0.2.6"
[dependencies.pin-utils]
version = "0.1.0"
@@ -73,21 +81,55 @@ optional = true
[dependencies.tokio-io]
version = "0.1.9"
optional = true
+
[dev-dependencies.tokio]
version = "0.1.11"
[features]
-alloc = ["futures-core/alloc", "futures-task/alloc"]
+alloc = [
+ "futures-core/alloc",
+ "futures-task/alloc",
+]
async-await = []
-async-await-macro = ["async-await", "futures-macro"]
+async-await-macro = [
+ "async-await",
+ "futures-macro",
+]
bilock = []
cfg-target-has-atomic = []
-channel = ["std", "futures-channel"]
-compat = ["std", "futures_01"]
-default = ["std", "async-await", "async-await-macro"]
-io = ["std", "futures-io", "memchr"]
-io-compat = ["io", "compat", "tokio-io"]
+channel = [
+ "std",
+ "futures-channel",
+]
+compat = [
+ "std",
+ "futures_01",
+]
+default = [
+ "std",
+ "async-await",
+ "async-await-macro",
+]
+io = [
+ "std",
+ "futures-io",
+ "memchr",
+]
+io-compat = [
+ "io",
+ "compat",
+ "tokio-io",
+]
+portable-atomic = ["futures-core/portable-atomic"]
sink = ["futures-sink"]
-std = ["alloc", "futures-core/std", "futures-task/std", "slab"]
-unstable = ["futures-core/unstable", "futures-task/unstable"]
+std = [
+ "alloc",
+ "futures-core/std",
+ "futures-task/std",
+ "slab",
+]
+unstable = [
+ "futures-core/unstable",
+ "futures-task/unstable",
+]
write-all-vectored = ["io"]