summaryrefslogtreecommitdiffstats
path: root/vendor/getopts/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/getopts/Cargo.toml')
-rw-r--r--vendor/getopts/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/vendor/getopts/Cargo.toml b/vendor/getopts/Cargo.toml
new file mode 100644
index 000000000..db224fcf5
--- /dev/null
+++ b/vendor/getopts/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "getopts"
+version = "0.2.21"
+authors = ["The Rust Project Developers"]
+description = "getopts-like option parsing.\n"
+homepage = "https://github.com/rust-lang/getopts"
+documentation = "https://doc.rust-lang.org/getopts"
+readme = "README.md"
+categories = ["command-line-interface"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-lang/getopts"
+[dependencies.core]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.std]
+version = "1.0"
+optional = true
+package = "rustc-std-workspace-std"
+
+[dependencies.unicode-width]
+version = "0.1.5"
+[dev-dependencies.log]
+version = "0.4"
+
+[features]
+rustc-dep-of-std = ["unicode-width/rustc-dep-of-std", "std", "core"]