summaryrefslogtreecommitdiffstats
path: root/vendor/gimli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gimli/Cargo.toml')
-rw-r--r--vendor/gimli/Cargo.toml91
1 files changed, 27 insertions, 64 deletions
diff --git a/vendor/gimli/Cargo.toml b/vendor/gimli/Cargo.toml
index f49444711..f7d9c9dc1 100644
--- a/vendor/gimli/Cargo.toml
+++ b/vendor/gimli/Cargo.toml
@@ -11,11 +11,16 @@
[package]
edition = "2018"
+rust-version = "1.60"
name = "gimli"
-version = "0.27.2"
-exclude = [
- "/releases/*",
- "/.github",
+version = "0.28.0"
+include = [
+ "/CHANGELOG.md",
+ "/Cargo.toml",
+ "/LICENSE-APACHE",
+ "/LICENSE-MIT",
+ "/README.md",
+ "/src",
]
description = "A library for reading and writing the DWARF debugging format."
documentation = "https://docs.rs/gimli"
@@ -33,6 +38,7 @@ categories = [
]
license = "MIT OR Apache-2.0"
repository = "https://github.com/gimli-rs/gimli"
+resolver = "2"
[profile.bench]
codegen-units = 1
@@ -42,28 +48,6 @@ split-debuginfo = "packed"
[profile.test]
split-debuginfo = "packed"
-[[example]]
-name = "simple"
-required-features = ["read"]
-
-[[example]]
-name = "simple_line"
-required-features = ["read"]
-
-[[example]]
-name = "dwarfdump"
-required-features = [
- "read",
- "std",
-]
-
-[[example]]
-name = "dwarf-validate"
-required-features = [
- "read",
- "std",
-]
-
[dependencies.alloc]
version = "1.0.0"
optional = true
@@ -79,12 +63,12 @@ optional = true
package = "rustc-std-workspace-core"
[dependencies.fallible-iterator]
-version = "0.2.0"
+version = "0.3.0"
optional = true
default-features = false
[dependencies.indexmap]
-version = "1.0.2"
+version = "2.0.0"
optional = true
[dependencies.stable_deref_trait]
@@ -92,55 +76,34 @@ version = "1.1.0"
optional = true
default-features = false
-[dev-dependencies.crossbeam]
-version = "0.8"
-
-[dev-dependencies.getopts]
-version = "0.2"
-
-[dev-dependencies.memmap2]
-version = "0.5.5"
-
-[dev-dependencies.num_cpus]
-version = "1"
-
-[dev-dependencies.object]
-version = "0.30.0"
-features = ["wasm"]
-
-[dev-dependencies.rayon]
-version = "1.0"
-
-[dev-dependencies.regex]
-version = "1"
-
[dev-dependencies.test-assembler]
version = "0.1.3"
-[dev-dependencies.typed-arena]
-version = "2"
-
[features]
default = [
- "read",
+ "read-all",
"write",
- "std",
- "fallible-iterator",
- "endian-reader",
]
endian-reader = [
"read",
- "stable_deref_trait",
+ "dep:stable_deref_trait",
]
+fallible-iterator = ["dep:fallible-iterator"]
read = ["read-core"]
+read-all = [
+ "read",
+ "std",
+ "fallible-iterator",
+ "endian-reader",
+]
read-core = []
rustc-dep-of-std = [
- "core",
- "alloc",
- "compiler_builtins",
+ "dep:core",
+ "dep:alloc",
+ "dep:compiler_builtins",
]
std = [
- "fallible-iterator/std",
- "stable_deref_trait/std",
+ "fallible-iterator?/std",
+ "stable_deref_trait?/std",
]
-write = ["indexmap"]
+write = ["dep:indexmap"]