summaryrefslogtreecommitdiffstats
path: root/vendor/gix-config/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-config/Cargo.toml')
-rw-r--r--vendor/gix-config/Cargo.toml117
1 files changed, 117 insertions, 0 deletions
diff --git a/vendor/gix-config/Cargo.toml b/vendor/gix-config/Cargo.toml
new file mode 100644
index 000000000..a688807f8
--- /dev/null
+++ b/vendor/gix-config/Cargo.toml
@@ -0,0 +1,117 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-config"
+version = "0.18.0"
+authors = ["Edward Shen <code@eddie.sh>"]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "README.md",
+ "CHANGELOG.md",
+]
+autotests = false
+description = "A gix-config file parser and editor from the gitoxide project"
+readme = "README.md"
+keywords = [
+ "gix-config",
+ "git",
+ "config",
+ "gitoxide",
+]
+categories = [
+ "config",
+ "parser-implementations",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+all-features = true
+features = ["document-features"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[[bench]]
+name = "large_config_file"
+path = "./benches/large_config_file.rs"
+harness = false
+
+[dependencies.bstr]
+version = "1.3.0"
+features = ["std"]
+default-features = false
+
+[dependencies.document-features]
+version = "0.2.0"
+optional = true
+
+[dependencies.gix-config-value]
+version = "^0.10.1"
+
+[dependencies.gix-features]
+version = "^0.28.0"
+
+[dependencies.gix-glob]
+version = "^0.5.5"
+
+[dependencies.gix-path]
+version = "^0.7.2"
+
+[dependencies.gix-ref]
+version = "^0.26.0"
+
+[dependencies.gix-sec]
+version = "^0.6.2"
+
+[dependencies.memchr]
+version = "2"
+
+[dependencies.nom]
+version = "7"
+features = ["std"]
+default_features = false
+
+[dependencies.once_cell]
+version = "1.14.0"
+
+[dependencies.serde]
+version = "1.0.114"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.smallvec]
+version = "1.9.0"
+
+[dependencies.thiserror]
+version = "1.0.26"
+
+[dependencies.unicode-bom]
+version = "1.1.4"
+
+[dev-dependencies.criterion]
+version = "0.4.0"
+
+[features]
+serde1 = [
+ "serde",
+ "bstr/serde",
+ "gix-sec/serde1",
+ "gix-ref/serde1",
+ "gix-glob/serde1",
+ "gix-config-value/serde1",
+]