summaryrefslogtreecommitdiffstats
path: root/vendor/gix-hash/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-hash/Cargo.toml')
-rw-r--r--vendor/gix-hash/Cargo.toml57
1 files changed, 57 insertions, 0 deletions
diff --git a/vendor/gix-hash/Cargo.toml b/vendor/gix-hash/Cargo.toml
new file mode 100644
index 000000000..1206fd543
--- /dev/null
+++ b/vendor/gix-hash/Cargo.toml
@@ -0,0 +1,57 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-hash"
+version = "0.10.3"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "CHANGELOG.md",
+]
+description = "Borrowed and owned git hash digests used to identify git objects"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+all-features = true
+features = ["document-features"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+test = false
+doctest = false
+
+[dependencies.document-features]
+version = "0.2.0"
+optional = true
+
+[dependencies.hex]
+version = "0.4.2"
+
+[dependencies.serde]
+version = "1.0.114"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.thiserror]
+version = "1.0.33"
+
+[dev-dependencies]
+
+[features]
+serde1 = ["serde"]