summaryrefslogtreecommitdiffstats
path: root/vendor/gix-ignore/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-ignore/Cargo.toml')
-rw-r--r--vendor/gix-ignore/Cargo.toml71
1 files changed, 71 insertions, 0 deletions
diff --git a/vendor/gix-ignore/Cargo.toml b/vendor/gix-ignore/Cargo.toml
new file mode 100644
index 000000000..c5ad46608
--- /dev/null
+++ b/vendor/gix-ignore/Cargo.toml
@@ -0,0 +1,71 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-ignore"
+version = "0.2.0"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "CHANGELOG.md",
+]
+description = "A WIP crate of the gitoxide project dealing .gitignore files"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+all-features = true
+features = ["document-features"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+doctest = false
+
+[dependencies.bstr]
+version = "1.3.0"
+features = [
+ "std",
+ "unicode",
+]
+default-features = false
+
+[dependencies.document-features]
+version = "0.2.1"
+optional = true
+
+[dependencies.gix-glob]
+version = "^0.7.0"
+
+[dependencies.gix-path]
+version = "^0.8.0"
+
+[dependencies.serde]
+version = "1.0.114"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.unicode-bom]
+version = "2.0.2"
+
+[dev-dependencies]
+
+[features]
+serde = [
+ "dep:serde",
+ "bstr/serde",
+ "gix-glob/serde",
+]