summaryrefslogtreecommitdiffstats
path: root/vendor/gix-prompt/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-prompt/Cargo.toml')
-rw-r--r--vendor/gix-prompt/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/vendor/gix-prompt/Cargo.toml b/vendor/gix-prompt/Cargo.toml
new file mode 100644
index 000000000..98d97e20e
--- /dev/null
+++ b/vendor/gix-prompt/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-prompt"
+version = "0.3.2"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "README.md",
+ "CHANGELOG.md",
+]
+description = "A crate of the gitoxide project for handling prompts in the terminal"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[lib]
+doctest = false
+
+[dependencies.gix-command]
+version = "^0.2.3"
+
+[dependencies.gix-config-value]
+version = "^0.10.1"
+
+[dependencies.parking_lot]
+version = "0.12.1"
+
+[dependencies.thiserror]
+version = "1.0.32"
+
+[dev-dependencies.expectrl]
+version = "0.6.0"
+
+[dev-dependencies.serial_test]
+version = "1.0.0"
+
+[target."cfg(unix)".dependencies.nix]
+version = "0.26.1"
+features = ["term"]
+default-features = false