summaryrefslogtreecommitdiffstats
path: root/vendor/gix-revwalk/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-revwalk/Cargo.toml')
-rw-r--r--vendor/gix-revwalk/Cargo.toml46
1 files changed, 46 insertions, 0 deletions
diff --git a/vendor/gix-revwalk/Cargo.toml b/vendor/gix-revwalk/Cargo.toml
new file mode 100644
index 000000000..aa131055f
--- /dev/null
+++ b/vendor/gix-revwalk/Cargo.toml
@@ -0,0 +1,46 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-revwalk"
+version = "0.1.0"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+ "CHANGELOG.md",
+]
+description = "A crate providing utilities for walking the revision graph"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[lib]
+doctest = false
+
+[dependencies.gix-commitgraph]
+version = "^0.16.0"
+
+[dependencies.gix-hash]
+version = "^0.11.2"
+
+[dependencies.gix-hashtable]
+version = "^0.2.1"
+
+[dependencies.gix-object]
+version = "^0.30.0"
+
+[dependencies.smallvec]
+version = "1.10.0"
+
+[dependencies.thiserror]
+version = "1.0.26"