summaryrefslogtreecommitdiffstats
path: root/vendor/gix-sec/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gix-sec/Cargo.toml')
-rw-r--r--vendor/gix-sec/Cargo.toml76
1 files changed, 76 insertions, 0 deletions
diff --git a/vendor/gix-sec/Cargo.toml b/vendor/gix-sec/Cargo.toml
new file mode 100644
index 000000000..87c36e0c1
--- /dev/null
+++ b/vendor/gix-sec/Cargo.toml
@@ -0,0 +1,76 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "gix-sec"
+version = "0.6.2"
+authors = ["Sebastian Thiel <sebastian.thiel@icloud.com>"]
+include = [
+ "src/**/*",
+ "CHANGELOG.md",
+]
+description = "A WIP crate of the gitoxide project providing a shared trust model"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/Byron/gitoxide"
+
+[package.metadata.docs.rs]
+all-features = true
+features = ["document-features"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+doctest = false
+
+[dependencies.bitflags]
+version = "1.3.2"
+
+[dependencies.document-features]
+version = "0.2.1"
+optional = true
+
+[dependencies.serde]
+version = "1.0.114"
+features = [
+ "std",
+ "derive",
+]
+optional = true
+default-features = false
+
+[dev-dependencies.tempfile]
+version = "3.3.0"
+
+[features]
+serde1 = ["serde"]
+
+[target."cfg(not(windows))".dependencies.libc]
+version = "0.2.123"
+
+[target."cfg(windows)".dependencies.dirs]
+version = "4"
+
+[target."cfg(windows)".dependencies.gix-path]
+version = "^0.7.1"
+
+[target."cfg(windows)".dependencies.windows]
+version = "0.43.0"
+features = [
+ "Win32_Foundation",
+ "Win32_Security_Authorization",
+ "Win32_Storage_FileSystem",
+ "Win32_System_Memory",
+ "Win32_System_Threading",
+]