summaryrefslogtreecommitdiffstats
path: root/vendor/hermit-abi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/hermit-abi/Cargo.toml')
-rw-r--r--vendor/hermit-abi/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/vendor/hermit-abi/Cargo.toml b/vendor/hermit-abi/Cargo.toml
new file mode 100644
index 000000000..81b32c9bf
--- /dev/null
+++ b/vendor/hermit-abi/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "hermit-abi"
+version = "0.2.0"
+authors = ["Stefan Lankes"]
+description = "hermit-abi is small interface to call functions from the unikernel RustyHermit.\nIt is used to build the target `x86_64-unknown-hermit`.\n"
+documentation = "https://hermitcore.github.io/rusty-hermit/hermit_abi"
+readme = "README.md"
+keywords = ["unikernel", "libos"]
+categories = ["os"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/hermitcore/rusty-hermit"
+[package.metadata.docs.rs]
+default-target = "x86_64-unknown-hermit"
+features = ["docs"]
+[dependencies.compiler_builtins]
+version = "0.1"
+optional = true
+
+[dependencies.core]
+version = "1.0.0"
+optional = true
+package = "rustc-std-workspace-core"
+
+[dependencies.libc]
+version = "0.2.51"
+default-features = false
+
+[features]
+default = []
+docs = []
+rustc-dep-of-std = ["core", "compiler_builtins/rustc-dep-of-std", "libc/rustc-dep-of-std"]