summaryrefslogtreecommitdiffstats
path: root/vendor/http-body/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/http-body/Cargo.toml')
-rw-r--r--vendor/http-body/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/vendor/http-body/Cargo.toml b/vendor/http-body/Cargo.toml
new file mode 100644
index 000000000..202ce7de8
--- /dev/null
+++ b/vendor/http-body/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "http-body"
+version = "0.4.5"
+authors = [
+ "Carl Lerche <me@carllerche.com>",
+ "Lucio Franco <luciofranco14@gmail.com>",
+ "Sean McArthur <sean@seanmonstar.com>",
+]
+description = """
+Trait representing an asynchronous, streaming, HTTP request or response body.
+"""
+documentation = "https://docs.rs/http-body"
+readme = "README.md"
+keywords = ["http"]
+categories = ["web-programming"]
+license = "MIT"
+repository = "https://github.com/hyperium/http-body"
+
+[dependencies.bytes]
+version = "1"
+
+[dependencies.http]
+version = "0.2"
+
+[dependencies.pin-project-lite]
+version = "0.2"
+
+[dev-dependencies.tokio]
+version = "1"
+features = [
+ "macros",
+ "rt",
+]