summaryrefslogtreecommitdiffstats
path: root/vendor/hyper-tls/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/hyper-tls/Cargo.toml')
-rw-r--r--vendor/hyper-tls/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/vendor/hyper-tls/Cargo.toml b/vendor/hyper-tls/Cargo.toml
new file mode 100644
index 000000000..f779c2222
--- /dev/null
+++ b/vendor/hyper-tls/Cargo.toml
@@ -0,0 +1,50 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "hyper-tls"
+version = "0.5.0"
+authors = ["Sean McArthur <sean@seanmonstar.com>"]
+description = "Default TLS implementation for use with hyper"
+homepage = "https://hyper.rs"
+documentation = "https://docs.rs/hyper-tls"
+keywords = ["hyper", "tls", "http", "https", "ssl"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/hyperium/hyper-tls"
+[dependencies.bytes]
+version = "1"
+
+[dependencies.hyper]
+version = "0.14.2"
+features = ["tcp", "client"]
+default-features = false
+
+[dependencies.native-tls]
+version = "0.2.1"
+
+[dependencies.tokio]
+version = "1"
+
+[dependencies.tokio-native-tls]
+version = "0.3"
+[dev-dependencies.hyper]
+version = "0.14.2"
+features = ["http1"]
+default-features = false
+
+[dev-dependencies.tokio]
+version = "1.0.0"
+features = ["io-std", "macros", "io-util"]
+
+[features]
+vendored = ["native-tls/vendored"]