summaryrefslogtreecommitdiffstats
path: root/vendor/icu_provider_adapters/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/icu_provider_adapters/Cargo.toml')
-rw-r--r--vendor/icu_provider_adapters/Cargo.toml88
1 files changed, 88 insertions, 0 deletions
diff --git a/vendor/icu_provider_adapters/Cargo.toml b/vendor/icu_provider_adapters/Cargo.toml
new file mode 100644
index 000000000..365a2a69b
--- /dev/null
+++ b/vendor/icu_provider_adapters/Cargo.toml
@@ -0,0 +1,88 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "icu_provider_adapters"
+version = "1.0.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "Adapters for composing and manipulating data providers."
+readme = "README.md"
+categories = ["internationalization"]
+license = "Unicode-DFS-2016"
+repository = "https://github.com/unicode-org/icu4x"
+resolver = "2"
+
+[dependencies.databake]
+version = "0.1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.icu_locid]
+version = "1.0.0"
+features = ["zerovec"]
+
+[dependencies.icu_provider]
+version = "1.0.0"
+features = ["macros"]
+
+[dependencies.serde]
+version = "1.0"
+features = [
+ "derive",
+ "alloc",
+]
+optional = true
+default-features = false
+
+[dependencies.tinystr]
+version = "0.7"
+features = ["zerovec"]
+
+[dependencies.yoke]
+version = "0.6"
+
+[dependencies.zerovec]
+version = "0.9"
+features = ["yoke"]
+
+[dev-dependencies.icu_provider]
+version = "1.0.0"
+features = [
+ "macros",
+ "deserialize_json",
+]
+
+[features]
+datagen = [
+ "std",
+ "serde",
+ "databake",
+ "icu_provider/datagen",
+ "icu_locid/databake",
+ "zerovec/databake",
+]
+serde = [
+ "dep:serde",
+ "zerovec/serde",
+ "icu_locid/serde",
+ "icu_provider/serde",
+]
+std = ["icu_locid/std"]