summaryrefslogtreecommitdiffstats
path: root/vendor/indexmap/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/indexmap/Cargo.toml')
-rw-r--r--vendor/indexmap/Cargo.toml32
1 files changed, 18 insertions, 14 deletions
diff --git a/vendor/indexmap/Cargo.toml b/vendor/indexmap/Cargo.toml
index 28f3618f0..d46c15d68 100644
--- a/vendor/indexmap/Cargo.toml
+++ b/vendor/indexmap/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.56"
+rust-version = "1.64"
name = "indexmap"
-version = "1.9.3"
+version = "2.0.0"
description = "A hash table with consistent order and fast iteration."
documentation = "https://docs.rs/indexmap/"
readme = "README.md"
@@ -28,17 +28,21 @@ categories = [
license = "Apache-2.0 OR MIT"
repository = "https://github.com/bluss/indexmap"
-[package.metadata.release]
-no-dev-version = true
-tag-name = "{{version}}"
-
[package.metadata.docs.rs]
features = [
"arbitrary",
"quickcheck",
- "serde-1",
+ "serde",
"rayon",
]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[package.metadata.release]
+no-dev-version = true
+tag-name = "{{version}}"
[profile.bench]
debug = true
@@ -51,8 +55,12 @@ version = "1.0"
optional = true
default-features = false
+[dependencies.equivalent]
+version = "1.0"
+default-features = false
+
[dependencies.hashbrown]
-version = "0.12"
+version = "0.14"
features = ["raw"]
default-features = false
@@ -62,7 +70,7 @@ optional = true
default-features = false
[dependencies.rayon]
-version = "1.4.1"
+version = "1.5.3"
optional = true
[dependencies.rustc-rayon]
@@ -98,11 +106,7 @@ features = ["small_rng"]
[dev-dependencies.serde_derive]
version = "1.0"
-[build-dependencies.autocfg]
-version = "1"
-
[features]
-serde-1 = ["serde"]
+default = ["std"]
std = []
test_debug = []
-test_low_transition_point = []