summaryrefslogtreecommitdiffstats
path: root/vendor/io-lifetimes/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/io-lifetimes/Cargo.toml')
-rw-r--r--vendor/io-lifetimes/Cargo.toml86
1 files changed, 86 insertions, 0 deletions
diff --git a/vendor/io-lifetimes/Cargo.toml b/vendor/io-lifetimes/Cargo.toml
new file mode 100644
index 000000000..2cc766559
--- /dev/null
+++ b/vendor/io-lifetimes/Cargo.toml
@@ -0,0 +1,86 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "io-lifetimes"
+version = "0.7.2"
+authors = ["Dan Gohman <dev@sunfishcode.online>"]
+exclude = ["/.github"]
+description = "A low-level I/O ownership and borrowing library"
+keywords = [
+ "api",
+ "io",
+]
+categories = [
+ "os",
+ "rust-patterns",
+]
+license = "Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT"
+repository = "https://github.com/sunfishcode/io-lifetimes"
+
+[dependencies.async-std]
+version = "1.9.0"
+features = ["unstable"]
+optional = true
+
+[dependencies.fs-err]
+version = "2.6.0"
+optional = true
+
+[dependencies.mio]
+version = "0.8.0"
+features = [
+ "net",
+ "os-ext",
+]
+optional = true
+
+[dependencies.socket2]
+version = "0.4.0"
+optional = true
+
+[dependencies.tokio]
+version = "1.6.0"
+features = [
+ "io-std",
+ "fs",
+ "net",
+ "process",
+]
+optional = true
+
+[features]
+close = [
+ "libc",
+ "windows-sys",
+]
+default = ["close"]
+
+[target."cfg(not(target_os = \"wasi\"))".dependencies.os_pipe]
+version = "1.0.0"
+optional = true
+
+[target."cfg(not(windows))".dependencies.libc]
+version = "0.2.96"
+optional = true
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.36.0"
+features = [
+ "Win32_Foundation",
+ "Win32_Storage_FileSystem",
+ "Win32_Networking_WinSock",
+ "Win32_Security",
+ "Win32_System_IO",
+ "Win32_System_Threading",
+]
+optional = true