summaryrefslogtreecommitdiffstats
path: root/vendor/line-index/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/line-index/Cargo.toml')
-rw-r--r--vendor/line-index/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/vendor/line-index/Cargo.toml b/vendor/line-index/Cargo.toml
new file mode 100644
index 000000000..06efc2071
--- /dev/null
+++ b/vendor/line-index/Cargo.toml
@@ -0,0 +1,25 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "line-index"
+version = "0.1.0-pre.1"
+description = "Maps flat `TextSize` offsets to/from `(line, column)` representation."
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/rust-analyzer/tree/master/lib/line-index"
+resolver = "1"
+
+[dependencies.nohash-hasher]
+version = "0.2.0"
+
+[dependencies.text-size]
+version = "1.1.0"