summaryrefslogtreecommitdiffstats
path: root/vendor/lock_api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/lock_api/Cargo.toml')
-rw-r--r--vendor/lock_api/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/vendor/lock_api/Cargo.toml b/vendor/lock_api/Cargo.toml
new file mode 100644
index 000000000..c1ebdb7b7
--- /dev/null
+++ b/vendor/lock_api/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "lock_api"
+version = "0.4.7"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "Wrappers to create fully-featured Mutex and RwLock types. Compatible with no_std."
+keywords = [
+ "mutex",
+ "rwlock",
+ "lock",
+ "no_std",
+]
+categories = [
+ "concurrency",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Amanieu/parking_lot"
+
+[dependencies.owning_ref]
+version = "0.4.1"
+optional = true
+
+[dependencies.scopeguard]
+version = "1.1.0"
+default-features = false
+
+[dependencies.serde]
+version = "1.0.126"
+optional = true
+default-features = false
+
+[build-dependencies.autocfg]
+version = "1.1.0"
+
+[features]
+arc_lock = []
+nightly = []