summaryrefslogtreecommitdiffstats
path: root/vendor/md-5/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/md-5/Cargo.toml')
-rw-r--r--vendor/md-5/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/vendor/md-5/Cargo.toml b/vendor/md-5/Cargo.toml
new file mode 100644
index 000000000..b65ecf0ec
--- /dev/null
+++ b/vendor/md-5/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "md-5"
+version = "0.10.0"
+authors = ["RustCrypto Developers"]
+description = "MD5 hash function"
+documentation = "https://docs.rs/md-5"
+readme = "README.md"
+keywords = ["crypto", "md5", "hash", "digest"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/hashes"
+
+[lib]
+name = "md5"
+[dependencies.digest]
+version = "0.10"
+
+[dependencies.md5-asm]
+version = "0.5"
+optional = true
+[dev-dependencies.digest]
+version = "0.10"
+features = ["dev"]
+
+[dev-dependencies.hex-literal]
+version = "0.2"
+
+[features]
+asm = ["md5-asm"]
+default = ["std"]
+std = ["digest/std"]