summaryrefslogtreecommitdiffstats
path: root/vendor/num_threads
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/num_threads')
-rw-r--r--vendor/num_threads/.cargo-checksum.json1
-rw-r--r--vendor/num_threads/Cargo.toml36
-rw-r--r--vendor/num_threads/LICENSE-Apache202
-rw-r--r--vendor/num_threads/LICENSE-MIT19
-rw-r--r--vendor/num_threads/src/apple.rs45
-rw-r--r--vendor/num_threads/src/freebsd.rs36
-rw-r--r--vendor/num_threads/src/imp.rs7
-rw-r--r--vendor/num_threads/src/lib.rs64
-rw-r--r--vendor/num_threads/src/linux.rs14
9 files changed, 424 insertions, 0 deletions
diff --git a/vendor/num_threads/.cargo-checksum.json b/vendor/num_threads/.cargo-checksum.json
new file mode 100644
index 000000000..603e1c7e7
--- /dev/null
+++ b/vendor/num_threads/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"ed1dbfb8f9eb836549858fb0ca704eddaa480cbe576e8dd50ebca1529dca21b3","LICENSE-Apache":"c69b72788ec261765e460532016b4bb78372f238e449b5e70e3268ec1e18fd15","LICENSE-MIT":"b4bf94a9fceb8846320fda938ee53fc16b506572609da5cf1d2d289a5597a8f8","src/apple.rs":"018e729ea67e8e17428d2e8d93f28ed0f7e7c506fcf78b56f56113235ce7dfcf","src/freebsd.rs":"683636294a62d6b958a5de800b52ddfea609234921e0583906272aacc71e18e5","src/imp.rs":"8cc9d07f05b0aa70e9997648abce7f79bd758c6fc76040d1c8f7beb7bf551e9d","src/lib.rs":"c53382612069b9552846414d1508cbb1401c500a4f34e21addd336001ebd8b7e","src/linux.rs":"67e02ecd105b8a421227bf72814e8388a4f77df1d8a44b8902bc8926f7e6698c"},"package":"2819ce041d2ee131036f4fc9d6ae7ae125a3a40e97ba64d04fe799ad9dabbb44"} \ No newline at end of file
diff --git a/vendor/num_threads/Cargo.toml b/vendor/num_threads/Cargo.toml
new file mode 100644
index 000000000..abfb41e97
--- /dev/null
+++ b/vendor/num_threads/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "num_threads"
+version = "0.1.6"
+authors = ["Jacob Pratt <open-source@jhpratt.dev>"]
+include = [
+ "src/**/*",
+ "LICENSE-*",
+]
+description = "A minimal library that determines the number of running threads for the current process."
+categories = [
+ "api-bindings",
+ "hardware-support",
+ "os",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/jhpratt/num_threads"
+
+[package.metadata.docs.rs]
+all-features = true
+targets = ["x86_64-unknown-linux-gnu"]
+
+[dependencies]
+
+[target."cfg(any(target_os = \"macos\", target_os = \"ios\", target_os = \"freebsd\"))".dependencies.libc]
+version = "0.2.107"
diff --git a/vendor/num_threads/LICENSE-Apache b/vendor/num_threads/LICENSE-Apache
new file mode 100644
index 000000000..8119b40f3
--- /dev/null
+++ b/vendor/num_threads/LICENSE-Apache
@@ -0,0 +1,202 @@
+
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright 2021 Jacob Pratt
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
diff --git a/vendor/num_threads/LICENSE-MIT b/vendor/num_threads/LICENSE-MIT
new file mode 100644
index 000000000..8daf82347
--- /dev/null
+++ b/vendor/num_threads/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2021 Jacob Pratt
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/vendor/num_threads/src/apple.rs b/vendor/num_threads/src/apple.rs
new file mode 100644
index 000000000..8d71b542d
--- /dev/null
+++ b/vendor/num_threads/src/apple.rs
@@ -0,0 +1,45 @@
+extern crate libc;
+
+use std::num::NonZeroUsize;
+
+use self::libc::{kern_return_t, mach_msg_type_number_t, mach_port_t, thread_t};
+
+// This constant is from
+// /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/
+// usr/include/mach/machine/thread_state.h.
+//
+// It has not been updated since Apple devices started to support 64-bit ARM (iOS), so it
+// should be very stable.
+const THREAD_STATE_MAX: i32 = 1296;
+#[allow(non_camel_case_types)]
+// https://github.com/apple/darwin-xnu/blob/a1babec6b135d1f35b2590a1990af3c5c5393479/osfmk/mach/mach_types.defs#L155
+type task_inspect_t = mach_port_t;
+#[allow(non_camel_case_types)]
+// https://github.com/apple/darwin-xnu/blob/a1babec6b135d1f35b2590a1990af3c5c5393479/osfmk/mach/mach_types.defs#L238
+type thread_array_t = [thread_t; THREAD_STATE_MAX as usize];
+
+extern "C" {
+ // https://developer.apple.com/documentation/kernel/1537751-task_threads/
+ fn task_threads(
+ target_task: task_inspect_t,
+ act_list: *mut thread_array_t,
+ act_listCnt: *mut mach_msg_type_number_t,
+ ) -> kern_return_t;
+}
+
+pub(crate) fn num_threads() -> Option<NonZeroUsize> {
+ // http://web.mit.edu/darwin/src/modules/xnu/osfmk/man/task_threads.html
+ let mut thread_state = [0u32; THREAD_STATE_MAX as usize];
+ let mut thread_count = 0;
+
+ // Safety: `mach_task_self` always returns a valid value, `thread_state` is large enough, and
+ // both it and `thread_count` are writable.
+ let result =
+ unsafe { task_threads(libc::mach_task_self(), &mut thread_state, &mut thread_count) };
+
+ if result == libc::KERN_SUCCESS {
+ NonZeroUsize::new(thread_count as usize)
+ } else {
+ None
+ }
+}
diff --git a/vendor/num_threads/src/freebsd.rs b/vendor/num_threads/src/freebsd.rs
new file mode 100644
index 000000000..1c3cbc82e
--- /dev/null
+++ b/vendor/num_threads/src/freebsd.rs
@@ -0,0 +1,36 @@
+extern crate libc;
+
+use std::num::NonZeroUsize;
+use std::{mem, ptr};
+
+pub(crate) fn num_threads() -> Option<NonZeroUsize> {
+ // Safety: `sysctl` and `getpid` are both thread-safe.
+ // `kip` is only accessed if sysctl() succeeds and agrees with the expected size,
+ // and the data only trusted if both its embedded size and pid match expectations
+ unsafe {
+ let pid = libc::getpid();
+ let mib: [libc::c_int; 4] = [libc::CTL_KERN, libc::KERN_PROC, libc::KERN_PROC_PID, pid];
+ let mut kip: libc::kinfo_proc = mem::zeroed();
+ let expected_kip_len = mem::size_of_val(&kip);
+ let mut kip_len = expected_kip_len;
+
+ let ret = libc::sysctl(
+ mib.as_ptr(),
+ mib.len() as u32,
+ &mut kip as *mut _ as *mut libc::c_void,
+ &mut kip_len,
+ ptr::null(),
+ 0,
+ );
+
+ if ret == 0
+ && kip_len == expected_kip_len
+ && kip.ki_structsize == expected_kip_len as i32
+ && kip.ki_pid == pid
+ {
+ NonZeroUsize::new(kip.ki_numthreads as usize)
+ } else {
+ None
+ }
+ }
+}
diff --git a/vendor/num_threads/src/imp.rs b/vendor/num_threads/src/imp.rs
new file mode 100644
index 000000000..b12465d49
--- /dev/null
+++ b/vendor/num_threads/src/imp.rs
@@ -0,0 +1,7 @@
+//! Fallback if no OS matches.
+
+use std::num::NonZeroUsize;
+
+pub(crate) fn num_threads() -> Option<NonZeroUsize> {
+ None
+}
diff --git a/vendor/num_threads/src/lib.rs b/vendor/num_threads/src/lib.rs
new file mode 100644
index 000000000..c21380282
--- /dev/null
+++ b/vendor/num_threads/src/lib.rs
@@ -0,0 +1,64 @@
+//! Minimum supported Rust version: 1.28
+
+use std::num::NonZeroUsize;
+
+#[cfg_attr(any(target_os = "linux", target_os = "android"), path = "linux.rs")]
+#[cfg_attr(target_os = "freebsd", path = "freebsd.rs")]
+#[cfg_attr(any(target_os = "macos", target_os = "ios"), path = "apple.rs")]
+mod imp;
+
+/// Obtain the number of threads currently part of the active process. Returns `None` if the number
+/// of threads cannot be determined.
+pub fn num_threads() -> Option<NonZeroUsize> {
+ imp::num_threads()
+}
+
+/// Determine if the current process is single-threaded. Returns `None` if the number of threads
+/// cannot be determined.
+pub fn is_single_threaded() -> Option<bool> {
+ num_threads().map(|n| n.get() == 1)
+}
+
+#[cfg(test)]
+mod test {
+ use std::num::NonZeroUsize;
+
+ // Run each expression in its own thread.
+ macro_rules! threaded {
+ ($first:expr;) => {
+ $first;
+ };
+ ($first:expr; $($rest:expr;)*) => {
+ $first;
+ ::std::thread::spawn(|| {
+ threaded!($($rest;)*);
+ })
+ .join()
+ .unwrap();
+ };
+ }
+
+ #[test]
+ fn num_threads() {
+ threaded! {
+ assert_eq!(super::num_threads().map(NonZeroUsize::get), Some(1));
+ assert_eq!(super::num_threads().map(NonZeroUsize::get), Some(2));
+ assert_eq!(super::num_threads().map(NonZeroUsize::get), Some(3));
+ assert_eq!(super::num_threads().map(NonZeroUsize::get), Some(4));
+ assert_eq!(super::num_threads().map(NonZeroUsize::get), Some(5));
+ assert_eq!(super::num_threads().map(NonZeroUsize::get), Some(6));
+ }
+ }
+
+ #[test]
+ fn is_single_threaded() {
+ threaded! {
+ assert_eq!(super::is_single_threaded(), Some(true));
+ assert_eq!(super::is_single_threaded(), Some(false));
+ assert_eq!(super::is_single_threaded(), Some(false));
+ assert_eq!(super::is_single_threaded(), Some(false));
+ assert_eq!(super::is_single_threaded(), Some(false));
+ assert_eq!(super::is_single_threaded(), Some(false));
+ }
+ }
+}
diff --git a/vendor/num_threads/src/linux.rs b/vendor/num_threads/src/linux.rs
new file mode 100644
index 000000000..641b6b129
--- /dev/null
+++ b/vendor/num_threads/src/linux.rs
@@ -0,0 +1,14 @@
+use std::fs;
+use std::num::NonZeroUsize;
+
+pub(crate) fn num_threads() -> Option<NonZeroUsize> {
+ fs::read_to_string("/proc/self/stat")
+ .ok()
+ .as_ref()
+ // Skip past the pid and (process name) fields
+ .and_then(|stat| stat.rsplit(')').next())
+ // 20th field, less the two we skipped
+ .and_then(|rstat| rstat.split_whitespace().nth(17))
+ .and_then(|num_threads| num_threads.parse::<usize>().ok())
+ .and_then(NonZeroUsize::new)
+}