summaryrefslogtreecommitdiffstats
path: root/vendor/object/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/object/Cargo.toml')
-rw-r--r--vendor/object/Cargo.toml28
1 files changed, 15 insertions, 13 deletions
diff --git a/vendor/object/Cargo.toml b/vendor/object/Cargo.toml
index 4ea28afcc..385666a10 100644
--- a/vendor/object/Cargo.toml
+++ b/vendor/object/Cargo.toml
@@ -11,8 +11,9 @@
[package]
edition = "2018"
+rust-version = "1.60"
name = "object"
-version = "0.31.1"
+version = "0.32.0"
exclude = [
"/.github",
"/testfiles",
@@ -57,25 +58,26 @@ version = "1"
optional = true
[dependencies.hashbrown]
-version = "0.13.1"
+version = "0.14.0"
features = ["ahash"]
optional = true
default-features = false
[dependencies.indexmap]
-version = "1.6"
+version = "2.0"
optional = true
+default-features = false
[dependencies.memchr]
version = "2.4.1"
default-features = false
[dependencies.ruzstd]
-version = "0.3.1"
+version = "0.4.0"
optional = true
[dependencies.wasmparser]
-version = "0.102.0"
+version = "0.110.0"
optional = true
[features]
@@ -90,8 +92,8 @@ archive = []
cargo-all = []
coff = []
compression = [
- "flate2",
- "ruzstd",
+ "dep:flate2",
+ "dep:ruzstd",
"std",
]
default = [
@@ -138,7 +140,7 @@ unstable-all = [
"all",
"unstable",
]
-wasm = ["wasmparser"]
+wasm = ["dep:wasmparser"]
write = [
"write_std",
"coff",
@@ -148,14 +150,14 @@ write = [
"xcoff",
]
write_core = [
- "crc32fast",
- "indexmap",
- "hashbrown",
+ "dep:crc32fast",
+ "dep:indexmap",
+ "dep:hashbrown",
]
write_std = [
"write_core",
"std",
- "indexmap/std",
- "crc32fast/std",
+ "indexmap?/std",
+ "crc32fast?/std",
]
xcoff = []