summaryrefslogtreecommitdiffstats
path: root/vendor/openssl-probe/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/openssl-probe/README.md')
-rw-r--r--vendor/openssl-probe/README.md33
1 files changed, 33 insertions, 0 deletions
diff --git a/vendor/openssl-probe/README.md b/vendor/openssl-probe/README.md
new file mode 100644
index 000000000..b0d7ab0c2
--- /dev/null
+++ b/vendor/openssl-probe/README.md
@@ -0,0 +1,33 @@
+# openssl-probe
+
+Tool for helping to find SSL certificate locations on the system for OpenSSL
+
+[![Crates.io](https://img.shields.io/crates/v/openssl-probe.svg?maxAge=2592000)](https://crates.io/crates/openssl-probe)
+[![docs.rs](https://docs.rs/openssl-probe/badge.svg)](https://docs.rs/openssl-probe/)
+
+## Usage
+
+First, add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+openssl-probe = "0.1.2"
+```
+
+Then add this to your crate:
+
+```rust
+extern crate openssl_probe;
+
+fn main() {
+ openssl_probe::init_ssl_cert_env_vars();
+ //... your code
+}
+```
+
+## License
+
+`openssl-probe` is primarily distributed under the terms of both the MIT license and the Apache License (Version 2.0),
+with portions covered by various BSD-like licenses.
+
+See [LICENSE-APACHE](./LICENSE-APACHE), and [LICENSE-MIT](LICENSE-MIT) for details.