summaryrefslogtreecommitdiffstats
path: root/vendor/openssl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/openssl/Cargo.toml')
-rw-r--r--vendor/openssl/Cargo.toml65
1 files changed, 65 insertions, 0 deletions
diff --git a/vendor/openssl/Cargo.toml b/vendor/openssl/Cargo.toml
new file mode 100644
index 000000000..e48618955
--- /dev/null
+++ b/vendor/openssl/Cargo.toml
@@ -0,0 +1,65 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "openssl"
+version = "0.10.49"
+authors = ["Steven Fackler <sfackler@gmail.com>"]
+description = "OpenSSL bindings"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "tls",
+ "ssl",
+ "dtls",
+]
+categories = [
+ "cryptography",
+ "api-bindings",
+]
+license = "Apache-2.0"
+repository = "https://github.com/sfackler/rust-openssl"
+
+[dependencies.bitflags]
+version = "1.0"
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.ffi]
+version = "0.9.84"
+package = "openssl-sys"
+
+[dependencies.foreign-types]
+version = "0.3.1"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.once_cell]
+version = "1.5.2"
+
+[dependencies.openssl-macros]
+version = "0.1.0"
+
+[dev-dependencies.hex]
+version = "0.3"
+
+[features]
+bindgen = ["ffi/bindgen"]
+default = []
+unstable_boringssl = ["ffi/unstable_boringssl"]
+v101 = []
+v102 = []
+v110 = []
+v111 = []
+vendored = ["ffi/vendored"]