summaryrefslogtreecommitdiffstats
path: root/vendor/parking_lot_core-0.8.6/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/parking_lot_core-0.8.6/Cargo.toml')
-rw-r--r--vendor/parking_lot_core-0.8.6/Cargo.toml74
1 files changed, 74 insertions, 0 deletions
diff --git a/vendor/parking_lot_core-0.8.6/Cargo.toml b/vendor/parking_lot_core-0.8.6/Cargo.toml
new file mode 100644
index 000000000..698151644
--- /dev/null
+++ b/vendor/parking_lot_core-0.8.6/Cargo.toml
@@ -0,0 +1,74 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "parking_lot_core"
+version = "0.8.6"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "An advanced API for creating custom synchronization primitives."
+keywords = [
+ "mutex",
+ "condvar",
+ "rwlock",
+ "once",
+ "thread",
+]
+categories = ["concurrency"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/Amanieu/parking_lot"
+
+[dependencies.backtrace]
+version = "0.3.60"
+optional = true
+
+[dependencies.cfg-if]
+version = "1.0.0"
+
+[dependencies.instant]
+version = "0.1.9"
+
+[dependencies.petgraph]
+version = "0.5.1"
+optional = true
+
+[dependencies.smallvec]
+version = "1.6.1"
+
+[dependencies.thread-id]
+version = "4.0.0"
+optional = true
+
+[features]
+deadlock_detection = [
+ "petgraph",
+ "thread-id",
+ "backtrace",
+]
+nightly = []
+
+[target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+version = "0.2.8"
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.95"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.9"
+features = [
+ "winnt",
+ "ntstatus",
+ "minwindef",
+ "winerror",
+ "winbase",
+ "errhandlingapi",
+ "handleapi",
+]