summaryrefslogtreecommitdiffstats
path: root/vendor/pem-rfc7468/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/pem-rfc7468/Cargo.toml')
-rw-r--r--vendor/pem-rfc7468/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/vendor/pem-rfc7468/Cargo.toml b/vendor/pem-rfc7468/Cargo.toml
new file mode 100644
index 000000000..2048a5d36
--- /dev/null
+++ b/vendor/pem-rfc7468/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56"
+name = "pem-rfc7468"
+version = "0.6.0"
+authors = ["RustCrypto Developers"]
+description = """
+PEM Encoding (RFC 7468) for PKIX, PKCS, and CMS Structures, implementing a
+strict subset of the original Privacy-Enhanced Mail encoding intended
+specifically for use with cryptographic keys, certificates, and other messages.
+Provides a no_std-friendly, constant-time implementation suitable for use with
+cryptographic private keys.
+"""
+readme = "README.md"
+keywords = [
+ "crypto",
+ "key",
+ "pem",
+ "pkcs",
+ "rsa",
+]
+categories = [
+ "cryptography",
+ "data-structures",
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/formats/tree/master/pem-rfc7468"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.base64ct]
+version = "1.4"
+
+[features]
+alloc = ["base64ct/alloc"]
+std = [
+ "alloc",
+ "base64ct/std",
+]