summaryrefslogtreecommitdiffstats
path: root/vendor/perf-event-open-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/perf-event-open-sys/Cargo.toml')
-rw-r--r--vendor/perf-event-open-sys/Cargo.toml29
1 files changed, 22 insertions, 7 deletions
diff --git a/vendor/perf-event-open-sys/Cargo.toml b/vendor/perf-event-open-sys/Cargo.toml
index 1fd0b9dd4..205237c82 100644
--- a/vendor/perf-event-open-sys/Cargo.toml
+++ b/vendor/perf-event-open-sys/Cargo.toml
@@ -3,21 +3,36 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "perf-event-open-sys"
-version = "1.0.1"
+version = "3.0.0"
authors = ["Jim Blandy <jimb@red-bean.com>"]
-description = "Unsafe, direct bindings for Linux's perf_event_open system call, with associated\ntypes and constants.\n"
+description = """
+Unsafe, direct bindings for Linux's perf_event_open system call, with associated
+types and constants.
+"""
+documentation = "https://docs.rs/perf-event-open-sys/"
readme = "README.md"
+keywords = [
+ "linux",
+ "perf",
+]
+categories = [
+ "external-ffi-bindings",
+ "development-tools::profiling",
+ "hardware-support",
+ "os::linux-apis",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/jimblandy/perf-event-open-sys.git"
+resolver = "2"
+
[dependencies.libc]
version = "0.2"