summaryrefslogtreecommitdiffstats
path: root/vendor/pest/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/pest/Cargo.toml')
-rw-r--r--vendor/pest/Cargo.toml19
1 files changed, 15 insertions, 4 deletions
diff --git a/vendor/pest/Cargo.toml b/vendor/pest/Cargo.toml
index 2358ffbff..80614f734 100644
--- a/vendor/pest/Cargo.toml
+++ b/vendor/pest/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.60"
+rust-version = "1.61"
name = "pest"
-version = "2.7.0"
+version = "2.7.5"
authors = ["DragoČ™ Tiselice <dragostiselice@gmail.com>"]
description = "The Elegant Parser"
homepage = "https://pest.rs/"
@@ -26,9 +26,13 @@ keywords = [
"grammar",
]
categories = ["parsing"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/pest-parser/pest"
+[[bench]]
+name = "stack"
+harness = false
+
[dependencies.memchr]
version = "2"
optional = true
@@ -49,9 +53,16 @@ optional = true
version = "0.1.5"
default-features = false
+[dev-dependencies.criterion]
+version = "0.5.1"
+features = ["html_reports"]
+
[features]
const_prec_climber = []
-default = ["std"]
+default = [
+ "std",
+ "memchr",
+]
pretty-print = [
"dep:serde",
"dep:serde_json",