summaryrefslogtreecommitdiffstats
path: root/vendor/phf/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/phf/Cargo.toml')
-rw-r--r--vendor/phf/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/vendor/phf/Cargo.toml b/vendor/phf/Cargo.toml
new file mode 100644
index 000000000..ca2ce9893
--- /dev/null
+++ b/vendor/phf/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "phf"
+version = "0.10.1"
+authors = ["Steven Fackler <sfackler@gmail.com>"]
+description = "Runtime support for perfect hash function data structures"
+readme = "../README.md"
+license = "MIT"
+repository = "https://github.com/sfackler/rust-phf"
+[package.metadata.docs.rs]
+features = ["macros"]
+
+[lib]
+name = "phf"
+path = "src/lib.rs"
+test = false
+[dependencies.phf_macros]
+version = "0.10.0"
+optional = true
+
+[dependencies.phf_shared]
+version = "0.10.0"
+default-features = false
+
+[dependencies.proc-macro-hack]
+version = "0.5.4"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[features]
+default = ["std"]
+macros = ["phf_macros", "proc-macro-hack"]
+std = ["phf_shared/std"]
+uncased = ["phf_shared/uncased"]
+unicase = ["phf_shared/unicase"]