summaryrefslogtreecommitdiffstats
path: root/vendor/pretty_assertions
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/pretty_assertions')
-rw-r--r--vendor/pretty_assertions/.cargo-checksum.json2
-rw-r--r--vendor/pretty_assertions/Cargo.lock84
-rw-r--r--vendor/pretty_assertions/Cargo.toml8
-rw-r--r--vendor/pretty_assertions/README.md4
-rw-r--r--vendor/pretty_assertions/src/lib.rs10
5 files changed, 11 insertions, 97 deletions
diff --git a/vendor/pretty_assertions/.cargo-checksum.json b/vendor/pretty_assertions/.cargo-checksum.json
index 18577e97d..c9df4eadd 100644
--- a/vendor/pretty_assertions/.cargo-checksum.json
+++ b/vendor/pretty_assertions/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.lock":"dc0a795e41222bca707fa04af294f8f8184a13bf9689a5160fa347c246484560","Cargo.toml":"89a0781c41f5e1da912bb4c3c617fe9eadc2ef4c326eeef9fd629b86071d3886","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"8c9612877aacfa1b42f5e80b679e6c3c93a7ba2bb99dfaf6e87e200dca4b4e6c","README.md":"151448d7f24d09a9615d1d9cf38b50e6f0c2c1d8273a447d88d2b70f37a6617f","examples/pretty_assertion.png":"a9a43d098b548cd222056e8f7391cc071ccd07372e9c44d10e254c0a683c7562","examples/pretty_assertion.rs":"41d0527d286baebe09149e33a9359c3e30c7fbfddd41995db4facdee291fcd2c","examples/pretty_assertion_v0_6_1.png":"c07a7a8cd56ebeb840ae8095c024957ddac8a1d011288acf7928f79d85b39e3a","examples/standard_assertion.png":"be6f676deb51d06bcb33f36d194c82228d5585d91f58af590d9040012e38a0a8","examples/standard_assertion.rs":"70180f493795da15c82c0002c26249ef2a1b9fa81f6d0c9a8e0bf4e09121e041","src/lib.rs":"f2362e53eda818ad2fc970ed9803099f07b6c27622ac2154871549a991cdc3bc","src/printer.rs":"3ea14e1542a47c9909bc06a7b413262a6d86dfd22ca15b220d6f6ea48ad35c8e","tests/macros.rs":"cadb699c6d1bab26bb7ba044b1094fdc8a1f4f670d70dc38b7defea1a4dd41fb"},"package":"a25e9bcb20aa780fd0bb16b72403a9064d6b3f22f026946029acb941a50af755"} \ No newline at end of file
+{"files":{"Cargo.lock":"82b613042345772f677258d6530e942a4ff34e7d31fe96bb504dab7d37441e3a","Cargo.toml":"cb01544b9fe71b7d344e566d73bc4332ab2c39bf6dca43d354b4b6372c4a6546","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"8c9612877aacfa1b42f5e80b679e6c3c93a7ba2bb99dfaf6e87e200dca4b4e6c","README.md":"56382a8b5347e3be95c26c97806291aebf5cc321090b19b2ac7d680461d4add1","examples/pretty_assertion.png":"a9a43d098b548cd222056e8f7391cc071ccd07372e9c44d10e254c0a683c7562","examples/pretty_assertion.rs":"41d0527d286baebe09149e33a9359c3e30c7fbfddd41995db4facdee291fcd2c","examples/pretty_assertion_v0_6_1.png":"c07a7a8cd56ebeb840ae8095c024957ddac8a1d011288acf7928f79d85b39e3a","examples/standard_assertion.png":"be6f676deb51d06bcb33f36d194c82228d5585d91f58af590d9040012e38a0a8","examples/standard_assertion.rs":"70180f493795da15c82c0002c26249ef2a1b9fa81f6d0c9a8e0bf4e09121e041","src/lib.rs":"6cd82626ccbd1401ed660f92eedac20efae01e9f5c7a9a5ce3203b6d20465d28","src/printer.rs":"3ea14e1542a47c9909bc06a7b413262a6d86dfd22ca15b220d6f6ea48ad35c8e","tests/macros.rs":"cadb699c6d1bab26bb7ba044b1094fdc8a1f4f670d70dc38b7defea1a4dd41fb"},"package":"af7cee1a6c8a5b9208b3cb1061f10c0cb689087b3d8ce85fb9d2dd7a29b6ba66"} \ No newline at end of file
diff --git a/vendor/pretty_assertions/Cargo.lock b/vendor/pretty_assertions/Cargo.lock
index baac97af0..94c73e134 100644
--- a/vendor/pretty_assertions/Cargo.lock
+++ b/vendor/pretty_assertions/Cargo.lock
@@ -1,98 +1,22 @@
# This file is automatically @generated by Cargo.
# It is not intended for manual editing.
-[[package]]
-name = "ctor"
-version = "0.1.19"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "e8f45d9ad417bcef4817d614a501ab55cdd96a6fdb24f49aab89a54acfd66b19"
-dependencies = [
- "quote",
- "syn",
-]
+version = 3
[[package]]
name = "diff"
-version = "0.1.12"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "0e25ea47919b1560c4e3b7fe0aaab9becf5b84a10325ddf7db0f0ba5e1026499"
-
-[[package]]
-name = "output_vt100"
-version = "0.1.2"
+version = "0.1.13"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "53cdc5b785b7a58c5aad8216b3dfa114df64b0b06ae6e1501cef91df2fbdf8f9"
-dependencies = [
- "winapi",
-]
+checksum = "56254986775e3233ffa9c4d7d3faaf6d36a2c09d30b20687e9f88bc8bafc16c8"
[[package]]
name = "pretty_assertions"
-version = "1.3.0"
+version = "1.4.0"
dependencies = [
- "ctor",
"diff",
- "output_vt100",
"yansi",
]
[[package]]
-name = "proc-macro2"
-version = "1.0.24"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "1e0704ee1a7e00d7bb417d0770ea303c1bccbabf0ef1667dae92b5967f5f8a71"
-dependencies = [
- "unicode-xid",
-]
-
-[[package]]
-name = "quote"
-version = "1.0.9"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "c3d0b9745dc2debf507c8422de05d7226cc1f0644216dfdfead988f9b1ab32a7"
-dependencies = [
- "proc-macro2",
-]
-
-[[package]]
-name = "syn"
-version = "1.0.63"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "8fd9bc7ccc2688b3344c2f48b9b546648b25ce0b20fc717ee7fa7981a8ca9717"
-dependencies = [
- "proc-macro2",
- "quote",
- "unicode-xid",
-]
-
-[[package]]
-name = "unicode-xid"
-version = "0.2.1"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "f7fe0bb3479651439c9112f72b6c505038574c9fbb575ed1bf3b797fa39dd564"
-
-[[package]]
-name = "winapi"
-version = "0.3.9"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "5c839a674fcd7a98952e593242ea400abe93992746761e38641405d28b00f419"
-dependencies = [
- "winapi-i686-pc-windows-gnu",
- "winapi-x86_64-pc-windows-gnu",
-]
-
-[[package]]
-name = "winapi-i686-pc-windows-gnu"
-version = "0.4.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
-
-[[package]]
-name = "winapi-x86_64-pc-windows-gnu"
-version = "0.4.0"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
-
-[[package]]
name = "yansi"
version = "0.5.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
diff --git a/vendor/pretty_assertions/Cargo.toml b/vendor/pretty_assertions/Cargo.toml
index f8370f7c3..d7dd8f09e 100644
--- a/vendor/pretty_assertions/Cargo.toml
+++ b/vendor/pretty_assertions/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "pretty_assertions"
-version = "1.3.0"
+version = "1.4.0"
authors = [
"Colin Kiegel <kiegel@gmx.de>",
"Florent Fayolle <florent.fayolle69@gmail.com>",
@@ -42,9 +42,3 @@ alloc = []
default = ["std"]
std = []
unstable = []
-
-[target."cfg(windows)".dependencies.ctor]
-version = "0.1.9"
-
-[target."cfg(windows)".dependencies.output_vt100]
-version = "0.1.2"
diff --git a/vendor/pretty_assertions/README.md b/vendor/pretty_assertions/README.md
index d9a5739b7..7bbb4cc3b 100644
--- a/vendor/pretty_assertions/README.md
+++ b/vendor/pretty_assertions/README.md
@@ -109,3 +109,7 @@ Unless you explicitly state otherwise, any contribution intentionally
submitted for inclusion in the work by you, as defined in the Apache-2.0
license, shall be dual licensed as above, without any additional terms or
conditions.
+
+## Development
+
+- Cut a new release by creating a GitHub release with tag. Crate will be built and uploaded to crates.io by GHA.
diff --git a/vendor/pretty_assertions/src/lib.rs b/vendor/pretty_assertions/src/lib.rs
index aebe08776..39db5cbd9 100644
--- a/vendor/pretty_assertions/src/lib.rs
+++ b/vendor/pretty_assertions/src/lib.rs
@@ -72,7 +72,7 @@
//! - `alloc`: Use the `alloc` crate.
//! Exactly one of `std` and `alloc` is required.
//! - `unstable`: opt-in to unstable features that may not follow Semantic Versioning.
-//! Implmenetion behind this feature is subject to change without warning between patch versions.
+//! The implementation behind this feature is subject to change without warning between patch versions.
#![cfg_attr(not(feature = "std"), no_std)]
#![deny(clippy::all, missing_docs, unsafe_code)]
@@ -84,14 +84,6 @@ use core::fmt::{self, Debug, Display};
mod printer;
-#[cfg(windows)]
-use ctor::*;
-#[cfg(windows)]
-#[ctor]
-fn init() {
- output_vt100::try_init().ok(); // Do not panic on fail
-}
-
/// A comparison of two values.
///
/// Where both values implement `Debug`, the comparison can be displayed as a pretty diff.