summaryrefslogtreecommitdiffstats
path: root/vendor/primeorder/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/primeorder/Cargo.toml')
-rw-r--r--vendor/primeorder/Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/vendor/primeorder/Cargo.toml b/vendor/primeorder/Cargo.toml
new file mode 100644
index 000000000..00deb8671
--- /dev/null
+++ b/vendor/primeorder/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "primeorder"
+version = "0.13.1"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of complete addition formulas for prime order elliptic
+curves (Renes-Costello-Batina 2015). Generic over field elements and curve
+equation coefficients
+"""
+documentation = "https://docs.rs/primeorder"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "ecc",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/elliptic-curves/tree/master/primeorder"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.elliptic-curve]
+version = "0.13"
+features = [
+ "arithmetic",
+ "sec1",
+]
+default-features = false
+
+[dependencies.serdect]
+version = "0.2"
+optional = true
+default-features = false
+
+[features]
+dev = []
+serde = [
+ "elliptic-curve/serde",
+ "serdect",
+]
+std = ["elliptic-curve/std"]