summaryrefslogtreecommitdiffstats
path: root/vendor/proc-macro-hack/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/proc-macro-hack/Cargo.toml')
-rw-r--r--vendor/proc-macro-hack/Cargo.toml17
1 files changed, 10 insertions, 7 deletions
diff --git a/vendor/proc-macro-hack/Cargo.toml b/vendor/proc-macro-hack/Cargo.toml
index 0fc674bb6..ec46c31a9 100644
--- a/vendor/proc-macro-hack/Cargo.toml
+++ b/vendor/proc-macro-hack/Cargo.toml
@@ -3,28 +3,30 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
+rust-version = "1.31"
name = "proc-macro-hack"
-version = "0.5.19"
+version = "0.5.20+deprecated"
authors = ["David Tolnay <dtolnay@gmail.com>"]
description = "Procedural macros in expression position"
readme = "README.md"
categories = ["development-tools::procedural-macro-helpers"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/dtolnay/proc-macro-hack"
+
[package.metadata.docs.rs]
targets = ["x86_64-unknown-linux-gnu"]
[lib]
proc-macro = true
+
[dev-dependencies.demo-hack]
version = "0.0.5"
@@ -41,4 +43,5 @@ version = "1.0"
version = "1.0.5"
[dev-dependencies.trybuild]
-version = "1.0"
+version = "1.0.49"
+features = ["diff"]