summaryrefslogtreecommitdiffstats
path: root/vendor/proptest/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/proptest/Cargo.toml')
-rw-r--r--vendor/proptest/Cargo.toml132
1 files changed, 132 insertions, 0 deletions
diff --git a/vendor/proptest/Cargo.toml b/vendor/proptest/Cargo.toml
new file mode 100644
index 000000000..1d03f9c0b
--- /dev/null
+++ b/vendor/proptest/Cargo.toml
@@ -0,0 +1,132 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "proptest"
+version = "1.1.0"
+authors = ["Jason Lingle"]
+exclude = [
+ "/gen-*.sh",
+ "/readme-*.md",
+]
+description = """
+Hypothesis-like property-based testing and shrinking.
+"""
+homepage = "https://altsysrq.github.io/proptest-book/proptest/index.html"
+documentation = "https://altsysrq.github.io/rustdoc/proptest/1.0.0/proptest/"
+readme = "README.md"
+keywords = [
+ "property",
+ "testing",
+ "quickcheck",
+ "fuzz",
+ "hypothesis",
+]
+categories = ["development-tools::testing"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/proptest-rs/proptest"
+
+[dependencies.bit-set]
+version = "0.5.0"
+optional = true
+
+[dependencies.bitflags]
+version = "1.0.1"
+
+[dependencies.byteorder]
+version = "1.2.3"
+default-features = false
+
+[dependencies.lazy_static]
+version = "1.2"
+optional = true
+
+[dependencies.num-traits]
+version = "0.2.15"
+features = ["libm"]
+default-features = false
+
+[dependencies.quick-error]
+version = "2.0.0"
+optional = true
+
+[dependencies.rand]
+version = "0.8"
+features = ["alloc"]
+default-features = false
+
+[dependencies.rand_chacha]
+version = "0.3"
+default-features = false
+
+[dependencies.rand_xorshift]
+version = "0.3"
+
+[dependencies.regex-syntax]
+version = "0.6.0"
+optional = true
+
+[dependencies.rusty-fork]
+version = "0.3.0"
+optional = true
+default-features = false
+
+[dependencies.tempfile]
+version = "3.0"
+optional = true
+
+[dependencies.unarray]
+version = "0.1.4"
+
+[dependencies.x86]
+version = "0.52.0"
+optional = true
+
+[dev-dependencies.regex]
+version = "1.0"
+
+[features]
+alloc = []
+atomic64bit = []
+break-dead-code = []
+default = [
+ "std",
+ "fork",
+ "timeout",
+ "bit-set",
+ "break-dead-code",
+]
+default-code-coverage = [
+ "std",
+ "fork",
+ "timeout",
+ "bit-set",
+]
+fork = [
+ "std",
+ "rusty-fork",
+ "tempfile",
+]
+hardware-rng = ["x86"]
+std = [
+ "rand/std",
+ "byteorder/std",
+ "lazy_static",
+ "quick-error",
+ "regex-syntax",
+ "num-traits/std",
+]
+timeout = [
+ "fork",
+ "rusty-fork/timeout",
+]
+unstable = []